CVE-2026-93680
Langflow OSS is affected by multiple vulnerabilities
Что произошло
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to bypass security restrictions due to improper authentication.
Что это значит
Проверка личности пользователя может работать неверно. Проверьте затронутый механизм входа и доступные ему ресурсы.
Что делать
1. Проверьте, затронуты ли вы
Соберите инвентаризацию и сравните с таблицей затронутых версий. Эти команды только показывают установленные компоненты и сами по себе не доказывают наличие CVE.
dpkg-query -W -f='${Package} ${Version}\n'rpm -qa --qf '%{NAME}\t%{VERSION}-%{RELEASE}\n'Get-HotFix | Select-Object HotFixID, InstalledOn
2. Установите исправление
Upgrade to Langflow OSS 1.13.0 or later. The latest release is available at https://github.com/langflow-ai/langflow/releases . Users deploying via pip may upgrade with: pip install langflow --upgrade. Users deploying via Docker should pull the latest tagged image.
3. Временные меры
До проверки бюллетеня ограничьте доступ к затронутому компоненту доверенными узлами. Оцените сегментацию и отключение ненужных интерфейсов с владельцем сервиса; универсального правила WAF для этой CVE не подтверждено.
4. Проверьте следы эксплуатации
Проверьте аномальные входы, новые учётные записи, ошибки и необычные дочерние процессы в затронутом сервисе. Публичные проверенные правила обнаружения не включены в запись; отсутствие сигналов не доказывает отсутствие компрометации.
5. После исправления
- Проверьте фактическую версию и результат установки по бюллетеню.
- При необходимости перезапустите сервисы в согласованное окно.
- Повторите проверку сканером и функциональные проверки.
- Зафиксируйте результат, дату, владельца и оставшийся риск.
Продукты и затронутые версии
IBM / Langflow OSS
{
"status": "affected",
"version": "1.0.0",
"versionType": "semver",
"lessThanOrEqual": "1.12.8"
}cpe:2.3:a:ibm:langflow_oss:1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:langflow_oss:1.12.8:*:*:*:*:*:*:*
CVSS: оценки и векторы
CVSS 3.1 · cve9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 · psirt@us.ibm.com9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 · ghsa9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Классы CWE
Источники и ссылки
Происхождение полей
{
"cwes": [
"cve",
"ghsa",
"nvd"
],
"title": {
"source": "cve",
"received_at": "2026-10-29T15:41:02.260348+00:00"
},
"scores": [
"cve",
"ghsa",
"nvd"
],
"status": {
"source": "cve",
"received_at": "2026-10-29T15:41:02.260348+00:00"
},
"affected": [
"cve"
],
"published": {
"source": "cve",
"received_at": "2026-10-29T15:41:02.260348+00:00"
},
"solutions": [
"cve"
],
"references": [
"cve",
"ghsa",
"nvd"
],
"description": {
"source": "cve",
"received_at": "2026-10-29T15:41:02.260348+00:00"
},
"workarounds": [],
"configurations": []
}Хронология записи
- Данные обновлены29.10.2026, 21:37
- Данные обновлены29.10.2026, 19:45
- Появились сведения об исправлении29.10.2026, 18:41
Личная заметка и статус
Другие CVE того же продукта
| УЯЗВИМОСТЬ / ПРОДУКТ | ПРИОРИТЕТ | CVSS | EPSS | СИГНАЛЫ | ОПУБЛИКОВАНА | Карточка |
|---|---|---|---|---|---|---|
| CVE-2026-18894 Langflow OSS is affected by multiple vulnerabilities IBM / Langflow OSS | Средний | 6.5 | — | Патч | 29.10.2026 | |
| CVE-2026-110309 Langflow OSS is affected by multiple vulnerabilities IBM / Langflow OSS | Высокий | 8.8 | — | Патч | 29.10.2026 | |
| CVE-2026-110193 Langflow OSS is affected by multiple vulnerabilities IBM / Langflow OSS | Высокий | 8.8 | — | Патч | 29.10.2026 | |
| CVE-2026-104339 Langflow OSS is affected by multiple vulnerabilities IBM / Langflow OSS | Критический | 9.8 | — | Патч | 29.10.2026 | |
| CVE-2026-104316 Langflow OSS is affected by multiple vulnerabilities IBM / Langflow OSS | Средний | 6.5 | — | Патч | 29.10.2026 |